Difference between revisions of "Installation/Development Setup"

From diaspora* project wiki
Jump to: navigation, search
(created)
 
 
(10 intermediate revisions by 3 users not shown)
Line 1: Line 1:
<div class="icon" style="padding:1em 0;">[[Image:Development.png|middle|link=|120px|]]
+
<div class="icon" style="padding:1em 0; margin:auto; width:50%;">[[Image:Development.png|middle|link=|120px|]]
   <div style="display:inline-block; vertical-align:middle; text-align:left; margin-left:3em;">
+
   <div style="display:inline-block; vertical-align:middle; text-align:left; ">
  
 
=== Development Setup ===
 
=== Development Setup ===
  
<span style="color:#F01;">'''Install the ''Requirements'' for your OS first!'''</span> <br>(See the specific guides above)
+
The guides above provide a version to get diaspora* running on your development machine. Just pick the one matching your OS and select "development" instead of production in the "Version of this guide". You can then check [[Getting_started_with_contributing|our guide on getting started with contributing]].
 
 
* Try the install script
 
* Manual Dev setup
 
  
 
   </div>
 
   </div>
 
</div>
 
</div>
 +
[[Category:Installation]]
 +
[[Category:Developers]]

Latest revision as of 11:59, 21 November 2018

Development.png

Development Setup

The guides above provide a version to get diaspora* running on your development machine. Just pick the one matching your OS and select "development" instead of production in the "Version of this guide". You can then check our guide on getting started with contributing.