Difference between revisions of "Installing on Ubuntu"

From diaspora* project wiki
Jump to: navigation, search
m (Preparations)
(Redirected page to Installation/Ubuntu)
 
(3 intermediate revisions by one other user not shown)
Line 1: Line 1:
__TOC__
+
#REDIRECT [[Installation/Ubuntu]]
 
 
== Preparations ==
 
 
 
You will need to make sure that your username is on the sudo authorized list located at '/etc/sudoers'.
 
 
 
== Install everything from APT  ==
 
If you're going through a proxy, add the following to the ~/.curlrc file:
 
<pre>proxy=host:port
 
proxy-user=username:password</pre>
 
 
 
=== Ubuntu 13.04 (Raring Ringtail) ===
 
<pre>
 
sudo apt-get install build-essential libxslt1.1 libxslt1-dev libxml2 ruby-full mysql-server libmysqlclient-dev libmysql-ruby \
 
libssl-dev libopenssl-ruby libcurl4-openssl-dev imagemagick libmagickwand-dev git-core redis-server libffi-dev libffi-ruby rubygems \
 
libsqlite3-dev libpq-dev libreadline5 openjdk-7-jre nodejs libncurses5-dev openssl libreadline6 libreadline6-dev curl git-core zlib1g \
 
zlib1g-dev libyaml-dev sqlite3 libxml2-dev libxslt-dev autoconf libc6-dev libgdbm-dev ncurses-dev automake libtool bison subversion pkg-config
 
</pre>
 
 
 
=== Ubuntu 12.10 (Quantal Quetzal) ===
 
<pre>
 
sudo apt-get install build-essential libxslt1.1 libxslt1-dev libxml2 ruby-full mysql-server libmysqlclient-dev libmysql-ruby libssl-dev \
 
libopenssl-ruby libcurl4-openssl-dev imagemagick libmagickwand-dev git-core redis-server libffi-dev libffi-ruby rubygems libsqlite3-dev \
 
libpq-dev libreadline5 openjdk-7-jre nodejs libncurses5-dev openssl libreadline6 libreadline6-dev curl git-core zlib1g zlib1g-dev libyaml-dev \
 
sqlite3 libxml2-dev libxslt-dev autoconf libc6-dev libgdbm-dev ncurses-dev automake libtool bison subversion pkg-config
 
</pre>
 
 
 
=== Ubuntu 12.04 LTS (Precise Pangolin) ===
 
<pre>
 
sudo apt-get install build-essential libxslt1.1 libxslt1-dev libxml2 ruby-full mysql-server libmysqlclient-dev libmysql-ruby libssl-dev \
 
libopenssl-ruby libcurl4-openssl-dev imagemagick libmagickwand-dev git-core redis-server libffi-dev libffi-ruby rubygems libsqlite3-dev libpq-dev \
 
libreadline5 openjdk-7-jre nodejs libncurses5-dev openssl libreadline6 libreadline6-dev curl git-core zlib1g zlib1g-dev libyaml-dev sqlite3 libxml2-dev \
 
libxslt-dev autoconf libc6-dev libgdbm-dev ncurses-dev automake libtool bison subversion pkg-config
 
</pre>
 
 
 
=== Ubuntu 11.10 (Oneiric Ocelot) ===
 
'''N.B. Support for Oneiric Ocelot 11.10 has officially ended on 13 October 2011 for both Desktop and Server Editions'''
 
 
 
<pre>
 
sudo apt-get install build-essential libxslt1.1 libxslt1-dev libxml2 ruby-full mysql-server libmysqlclient-dev libmysql-ruby libssl-dev libopenssl-ruby \
 
libcurl4-openssl-dev imagemagick libmagickwand-dev git-core redis-server libffi-dev libffi-ruby rubygems libsqlite3-dev libpq-dev libreadline-gplv2-dev \
 
openjdk-7-jre nodejs
 
</pre>
 
 
 
=== Ubuntu 10.10 (Maverick Meerkat) ===
 
'''N.B. Support for Maverick Meerkat 10.10 has officially ended on 10 October 2010 for both Desktop and Server Editions'''
 
 
 
<pre>
 
sudo apt-get install build-essential libxslt1.1 libxslt1-dev libxml2 ruby-full mysql-server libmysqlclient-dev libmysql-ruby libssl-dev libopenssl-ruby \
 
libcurl4-openssl-dev imagemagick libmagickwand-dev git-core redis-server libffi-dev libffi-ruby rubygems libsqlite3-dev libpq-dev libreadline5-dev nodejs
 
</pre>
 
 
 
=== Ubuntu 10.04 LTS (Lucid Lynx) ===
 
'''N.B. Support for Ubuntu Lucid Lynx 10.04 has officially ended on 9 May 2013 for the Desktop Edition. Server Edition is still supported until April 2015.'''
 
 
 
<pre>
 
sudo apt-get install build-essential libxslt1.1 libxslt1-dev libxml2 ruby-full mysql-server libmysqlclient-dev libmysql-ruby libssl-dev libopenssl-ruby \
 
libcurl4-openssl-dev imagemagick libmagickwand-dev git-core redis-server libffi-dev libffi-ruby rubygems libsqlite3-dev libpq-dev libreadline5-dev
 
</pre>
 
 
 
NodeJS needs to be built from source on 10.04.
 
<pre>
 
git clone git://github.com/ry/node.git
 
cd node
 
./configure
 
make
 
sudo make install
 
</pre>
 
 
 
== All Releases (no RVM) ==
 
For all Ubuntu releases run this if you are not going to use RVM:
 
<pre>wget http://ftp.us.debian.org/debian/pool/main/r/rubygems/rubygems_1.8.24-1_all.deb -O rubygems.deb && sudo dpkg -i rubygems.deb</pre>
 
 
 
== Install RVM (optional but currently highly recommended) ==
 
You can install Ruby on a clean per user basis via [http://rvm.io RVM]. This is currently recommended to get the latest Rubygems version. It is recommended that you install rvm from source since Ubuntu's version is lagging.
 
 
 
To install rvm from source, execute the following command:
 
<pre>curl -L get.rvm.io | bash -s stable --auto</pre>
 
 
 
Now read rvm requirements and ensure libyaml-dev is installed. Then install Ruby via RVM:
 
<pre>rvm install 1.9.3-p448
 
rvm use ruby-1.9.3-p448@global</pre>
 
 
 
== Install Bundler ==
 
To install Bundler, run the following, if you aren't using RVM you need to do it as root (prepend it with sudo):
 
 
 
<pre>gem install bundler --no-ri --no-rdoc</pre>
 
To get bundle to work (bundle install step later), you might need to make a symbolic link if you aren't using RVM:
 
 
 
<pre>sudo ln -s /var/lib/gems/1.8/bin/bundle /usr/local/bin/bundle</pre>
 
 
 
== Done! ==
 
Congrats! You have all your dependencies installed. Go back to [[Notes On Installing and Running Diaspora|Installing and Running Diaspora]]
 
 
 
== Appendix ==
 
 
 
=== Build Tools ===
 
 
 
To install build tools, run the following (includes the gcc and xml parsing dependencies):
 
<pre>sudo apt-get install build-essential libxslt1.1 libxslt1-dev libxml2</pre>
 
 
 
=== Ruby ===
 
To install Ruby 1.8.7, run the following command:
 
<pre>sudo apt-get install ruby-full</pre>
 
Please note that you need to have Universe enabled in your /etc/apt/sources.list file to install ruby using apt-get.
 
 
 
=== MySQL ===
 
 
 
This installs MySQL, you also need the libmysqlclient-dev and libmysql-ruby packages.
 
<pre>sudo apt-get install mysql-server libmysqlclient-dev libmysql-ruby</pre>
 
 
 
To start MySQL run:
 
<pre>sudo service mysql start</pre>
 
 
 
=== sqlite ===
 
<pre>sudo apt-get install libsqlite3-dev</pre>
 
 
 
=== OpenSSL ===
 
You already have OpenSSL installed but you need the libssl-dev and libopenssl-ruby package too:
 
 
 
<pre>sudo apt-get install libssl-dev libopenssl-ruby</pre>
 
 
 
=== libcurl ===
 
You need to install the dev headers. To install them, run the following:
 
 
 
<pre>sudo apt-get install libcurl4-openssl-dev</pre>
 
 
 
=== ImageMagick ===
 
To install ImageMagick, run the following:
 
<pre>sudo apt-get install imagemagick libmagick9-dev</pre>
 
 
 
If you're on Ubuntu 10.10 or 12.04 use the following instead:
 
<pre>sudo apt-get install imagemagick libmagickwand-dev</pre>
 
 
 
=== Git ===
 
To install Git, run the following:
 
<pre>sudo apt-get install git-core</pre>
 
 
 
=== Redis ===
 
To install Redis, run the following:
 
<pre>sudo apt-get install redis-server</pre>
 
 
 
=== ffi ===
 
Note: If you get an error in the next step try to run
 
<pre>sudo apt-get install libffi-dev libffi-ruby</pre>
 
and try the step again.
 
 
 
=== RubyGems ===
 
To install RubyGems run
 
<pre>wget http://ftp.us.debian.org/debian/pool/main/r/rubygems/rubygems_1.8.24-1_all.deb -O rubygems.deb && sudo dpkg -i rubygems.deb</pre>
 
[[Category:Podmin]]
 
[[Category:Installation]]
 
[[Category:Github transfer done]]
 

Latest revision as of 23:23, 19 July 2013