Talk:Installation/Debian/Wheezy

From diaspora* project wiki
Jump to: navigation, search

Troubleshooting:

ERROR: Gem bundler is not installed, run `gem install bundler` first.

gem install bundler

Did you skip RVM? Because the last time I tried that installed bundler right with installing a new Ruby. --MrZYX (talk) 07:39, 14 July 2013 (UTC)
Nope, I did "everything" (more or less) as said in the guide. -- DeusFigendi (talk) 07:53, 14 July 2013 (UTC)

libxml2 is missing. please visit http://nokogiri.org/tutorials/installing_nokogiri.html for help with installing dependencies.

sudo apt-get install libxslt-dev libxml2-dev

Likewise, getting the deps to build Ruby via RVM includes those. --MrZYX (talk) 07:39, 14 July 2013 (UTC)
Hmm, dunno, the bundler told me this http://paste.mrzyx.de/p1c4198e9/ and Dennis told me what to install (because the hints behind the link are talking about 1.8 and.... I just felt a little uncertain so I asked). -- DeusFigendi (talk) 07:53, 14 July 2013 (UTC)
Do you have the log from the RVM section by any chance then? --MrZYX (talk) 08:04, 14 July 2013 (UTC)
If it doesn't log to somewhere no... but I could do the whole process again (and maybe document everything). -- DeusFigendi (talk) 08:49, 14 July 2013 (UTC)

Can't install RMagick 2.13.2. Can't find Magick-config

  • sudo apt-get install librmagick-ruby
  • sudo apt-get install graphicsmagick-libmagick-dev-compat
As said below with the development version of the guide installing libmagickwand-dev should've solved that. Can you give more feedback? --MrZYX (talk) 07:37, 14 July 2013 (UTC)
You are right, I used to follow the production-guide and changed the bundle to development, I didn't know about a special dev-guide. So if I got it right this problem should not apear. Anyways a decided installation-troubleshooting-page might be usefull that sais exactly this: "You're probably trying to install a dev-pod using the prod-guide, please follow the instructions for development pods if you want to install one." Or something like this. There are more idiots out there not just me. -- DeusFigendi (talk) 07:53, 14 July 2013 (UTC)
A troubleshooting site might be a good idea, but then we'd need to make effort that it stays OS independent, allowing OS dependent hints leads to the old "if this then this" blabla that nobody understands after some time and making one for each guide seems like quite a lot extra pages. --MrZYX (talk) 08:04, 14 July 2013 (UTC)
Hmm I see, you're probably right... but one should be able to find solution when she searches for exact error-messages. So hum... maybe in User-Namespace. "I had this problem, this helped me:" -- DeusFigendi (talk) 08:56, 14 July 2013 (UTC)
Hm, no I don't think personal experience stuff helps, that just leads to more stuff that ages and maybe even conflicting hints. And somebody who has a different experience but isn't convinced about the fact wouldn't clean it up since it's in somebodies "territory" --MrZYX (talk) 20:29, 15 July 2013 (UTC)

Can't install RMagick 2.13.2. Can't find MagickWand.h.

sudo apt-get install libmagickwand-dev

Hm, in the development version, the installation of libmagickwand-dev should've solved that, in the production version running bundle install --without development test should've avoided that because that doesn't try to install rmagick. --MrZYX (talk) 07:35, 14 July 2013 (UTC)

RVM command is broken

I'm sure this string doesn't work. i used command from rvm.io

   curl -L dspr.tk/1t | bash

check it please and change if i'm right

Should be fixed, thanks for notifying. --MrZYX (talk) 12:11, 15 September 2013 (UTC)

libmagickwand-dev

Hey, User:Nocti can you explain the libmagickwand-dev change a bit more? What gem would depend on it? We have two that use ImageMagick, mini_magick and rmagick. mini_magick works by calling the ImageMagick commands through the commandline, thus it doesn't need to link against the lib. rmagick does link against the lib, but is only used in the testing environment and even there only on a special task to compare screenshots. Thus libmagickwand-dev still shouldn't be needed in production. --MrZYX (talk) 18:52, 21 October 2013 (UTC)

User:MrZYX, I believe it's the gem rmagick if I look at my tmux history for my install session.

--User:Nocti 14:09 2013-10-22

Which shouldn't be installed if you specify bundle install --without development