Difference between revisions of "Template:Installation/Common"

From diaspora* project wiki
Jump to: navigation, search
(bundler fixed in 0.6.0.1)
(Bundle: Explain how to handle the sigar build issue.)
Line 36: Line 36:
  
 
Running the manual <tt>gem install</tt> command shown in the error message can sometimes show a clearer error message if the <tt>bundle</tt> command fails.
 
Running the manual <tt>gem install</tt> command shown in the error message can sometimes show a clearer error message if the <tt>bundle</tt> command fails.
 +
 +
{{#ifeq: {{#var:version}}|Wheezy||Note: If you are installing on testing/stretch, you will need to rebuild the sigar gem.  To do this, you need to run:
 +
 +
<syntaxhighlight lang="bash">
 +
GEM_HOME=vendor/bundle/ruby/2.3.0 gem uninstall sigar
 +
bundle config --local build.sigar '--with-cppflags="-fgnu89-inline"'
 +
</syntaxhighlight>
 +
 +
Afterwards, you need to re-run the <tt>bundle install</tt> command.
 +
 +
(It might be possible to run this sigar build prior to running the initial <tt>bundle install</tt> command, but this has not been tested.)}}
  
 
== Database setup ==
 
== Database setup ==

Revision as of 23:34, 12 January 2017

Get the source

It's time to download diaspora*! As your diaspora user run:

cd ~
git clone  https://github.com/diaspora/diaspora.git
cd diaspora

Don't miss the cd diaspora, all coming commands expect to be run from that directory!

Configuration

Copy files

cp config/database.yml.example config/database.yml
cp config/diaspora.yml.example config/diaspora.yml


Bundle

It's time to install the Ruby libraries required by diaspora*:

gem install bundler
bin/bundle install  --with

This takes quite a while. When it's finished, you should see a message similar to: Bundle complete! 137 Gemfile dependencies, 259 gems now installed. If that's not the case, you should seek for help on the mailing list or the IRC channel. The --jobs $(nproc) flag speeds things a bit since it enables parallel downloading. nproc shows the number of CPU cores you have available.

Running the manual gem install command shown in the error message can sometimes show a clearer error message if the bundle command fails.

Note: If you are installing on testing/stretch, you will need to rebuild the sigar gem. To do this, you need to run:

GEM_HOME=vendor/bundle/ruby/2.3.0 gem uninstall sigar
bundle config --local build.sigar '--with-cppflags="-fgnu89-inline"'

Afterwards, you need to re-run the bundle install command.

(It might be possible to run this sigar build prior to running the initial bundle install command, but this has not been tested.)

Database setup

Double check your config/database.yml looks right and run:

bin/rake db:create db:schema:load

Start diaspora*

It's time to start diaspora*:

./script/server


Further reading