Difference between revisions of "Template:Installation/Configuration"

From diaspora* project wiki
Jump to: navigation, search
Line 6: Line 6:
 
* '''environment.certificate_authorities''': You have to set this, one of the examples should fit. If the file in the example doesn't exist you're missing a package, in most cases it's named <tt>ca-certificates</tt>.
 
* '''environment.certificate_authorities''': You have to set this, one of the examples should fit. If the file in the example doesn't exist you're missing a package, in most cases it's named <tt>ca-certificates</tt>.
 
* '''server.rails_environment''': You '''must''' set this to <tt>{{#var:mode}}</tt>. The <tt>server</tt> section is read by <tt>./script/server</tt> and most alternative startup methods to setup the correct environment.
 
* '''server.rails_environment''': You '''must''' set this to <tt>{{#var:mode}}</tt>. The <tt>server</tt> section is read by <tt>./script/server</tt> and most alternative startup methods to setup the correct environment.
{{#ifeq: {{#var:DB}}|postgres|* '''server.database''': Make sure this is set to <tt>{{#var:DB}}</tt>.}}
 
 
* '''environment.require_ssl''': If for some reason you can't run your pod on HTTPS (we highly encourage you to do it!), set this to <tt>false</tt> to prevent a redirect from <tt>http://</tt> to <tt>https://</tt>
 
* '''environment.require_ssl''': If for some reason you can't run your pod on HTTPS (we highly encourage you to do it!), set this to <tt>false</tt> to prevent a redirect from <tt>http://</tt> to <tt>https://</tt>

Revision as of 18:34, 10 September 2013

Now open config/database.yml and config/diaspora.yml in your favorite text editor and carefully review them, they are extensively commented.

Important values in config/diaspora.yml

  • environment.url: Set the public facing URL to your pod here, for example for https://pod.geraspora.de this would be https://pod.geraspora.de
  • environment.certificate_authorities: You have to set this, one of the examples should fit. If the file in the example doesn't exist you're missing a package, in most cases it's named ca-certificates.
  • server.rails_environment: You must set this to . The server section is read by ./script/server and most alternative startup methods to setup the correct environment.
  • environment.require_ssl: If for some reason you can't run your pod on HTTPS (we highly encourage you to do it!), set this to false to prevent a redirect from http:// to https://