Difference between revisions of "Template:Installation/Preparation/Debian"

From diaspora* project wiki
Jump to: navigation, search
(Install Packages: add cmake as dev dependency (from ubuntu deps))
(Install Packages: cmake is required for the rugged gem)
 
(One intermediate revision by one other user not shown)
Line 4: Line 4:
  
 
{{#tag:syntaxhighlight|
 
{{#tag:syntaxhighlight|
apt-get install build-essential libssl-dev libcurl4-openssl-dev libxml2-dev libxslt-dev imagemagick ghostscript curl libmagickwand-dev git {{#switch: {{#var:DB}}|mysql=libmysqlclient-dev|postgres=libpq-dev|mariadb=libmariadbclient-dev}}{{#ifeq: {{#var:mode}}|development|<nowiki/> cmake|}}{{#ifeq: {{#var:version}}|Wheezy|<nowiki/>
+
apt-get install build-essential cmake libssl-dev libcurl4-openssl-dev libxml2-dev libxslt-dev{{#ifeq: {{#var:mode}}|development|<nowiki/> libidn11-dev|}} imagemagick ghostscript curl libmagickwand-dev git {{#switch: {{#var:DB}}|mysql=libmysqlclient-dev|postgres=libpq-dev|mariadb=libmariadbclient-dev}}{{#ifeq: {{#var:mode}}|development|<nowiki/> cmake|}}{{#ifeq: {{#var:version}}|Wheezy|<nowiki/>
 
apt-get install -t wheezy-backports}} redis-server nodejs
 
apt-get install -t wheezy-backports}} redis-server nodejs
 
|lang=bash}}
 
|lang=bash}}

Latest revision as of 21:17, 8 October 2018

Install Packages

As root run:

apt-get install build-essential cmake libssl-dev libcurl4-openssl-dev libxml2-dev libxslt-dev imagemagick ghostscript curl libmagickwand-dev git  redis-server nodejs


Install the database

Skip this step if you already have one.

See the Debian wiki.