Difference between revisions of "Template:Installation/Preparation/Debian"

From diaspora* project wiki
Jump to: navigation, search
(Install Packages: add libidn11-dev as dependency for develop branch)
(Fix libxslt1-dev)
 
(2 intermediate revisions by 2 users not shown)
Line 4: Line 4:
  
 
{{#tag:syntaxhighlight|
 
{{#tag:syntaxhighlight|
apt-get install build-essential libssl-dev libcurl4-openssl-dev libxml2-dev libxslt-dev{{#ifeq: {{#var:mode}}|development|<nowiki/> libidn11-dev|}} imagemagick ghostscript curl libmagickwand-dev git {{#switch: {{#var:DB}}|mysql=libmysqlclient-dev|postgres=libpq-dev|mariadb=libmariadbclient-dev}}{{#ifeq: {{#var:mode}}|development|<nowiki/> cmake|}}{{#ifeq: {{#var:version}}|Wheezy|<nowiki/>
+
apt-get install build-essential git curl gsfonts imagemagick libmagickwand-dev nodejs redis-server libssl-dev libcurl4-openssl-dev libxml2-dev libxslt1-dev {{#ifeq: {{#var:mode}}|development|libidn11-dev <nowiki/>|}}{{#switch: {{#var:DB}}|mysql=default-libmysqlclient-dev|postgres=libpq-dev|mariadb=default-libmysqlclient-dev}}{{#ifeq: {{#var:mode}}|development|<nowiki/> cmake|}}
apt-get install -t wheezy-backports}} redis-server nodejs
 
 
|lang=bash}}
 
|lang=bash}}
{{#ifeq: {{#var:version}}|Wheezy|{{Template:Installation/Debian/Curl}}}}
 
  
 
=== Install the database ===
 
=== Install the database ===

Latest revision as of 00:49, 4 November 2020

Install Packages

As root run:

apt-get install build-essential git curl gsfonts imagemagick libmagickwand-dev nodejs redis-server libssl-dev libcurl4-openssl-dev libxml2-dev libxslt1-dev

Install the database

Skip this step if you already have one.

See the Debian wiki.