Template:Installation/Preparation/Debian

From diaspora* project wiki
< Template:Installation‎ | Preparation
Revision as of 21:17, 8 October 2018 by Senya (talk | contribs) (Install Packages: cmake is required for the rugged gem)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Install Packages

As root run:

apt-get install build-essential cmake libssl-dev libcurl4-openssl-dev libxml2-dev libxslt-dev imagemagick ghostscript curl libmagickwand-dev git  redis-server nodejs


Install the database

Skip this step if you already have one.

See the Debian wiki.