Difference between revisions of "Template:Installation/Preparation/Ubuntu"

From diaspora* project wiki
Jump to: navigation, search
(Install packages)
(Install packages: add some more dependencies)
Line 5: Line 5:
 
{{#tag:syntaxhighlight|
 
{{#tag:syntaxhighlight|
 
sudo apt-get update
 
sudo apt-get update
sudo apt-get install build-essential git curl imagemagick libmagickwand-dev nodejs redis-server libcurl4-openssl-dev libxml2-dev libxslt1-dev {{#ifeq: {{#var:version}}|Precise||libgmp-dev <nowiki/>}}{{#switch: {{#var:DB}}|mysql=libmysqlclient-dev|postgres=libpq-dev}}{{#ifeq: {{#var:mode}}|development|<nowiki/> libmagickwand-dev cmake|}}
+
sudo apt-get install build-essential git curl imagemagick libmagickwand-dev nodejs redis-server libssl-dev libcurl4-openssl-dev libxml2-dev libxslt1-dev {{#ifeq: {{#var:version}}|Precise||libgmp-dev <nowiki/>}}{{#switch: {{#var:DB}}|mysql=libmysqlclient-dev|postgres=libpq-dev|mariadb=libmysqlclient-dev}}{{#ifeq: {{#var:mode}}|development|<nowiki/> cmake|}}
 
|lang=bash}}
 
|lang=bash}}
 
{{#ifeq: {{#var:version}}|Precise|
 
{{#ifeq: {{#var:version}}|Precise|

Revision as of 22:50, 10 July 2017

Install packages

Run:

sudo apt-get update
sudo apt-get install build-essential git curl imagemagick libmagickwand-dev nodejs redis-server libssl-dev libcurl4-openssl-dev libxml2-dev libxslt1-dev libgmp-dev


Install the database

Skip this step if you already have one.

See the Ubuntu server guide.

Removing packaged version of RVM

If you installed RVM via the package manager, we recommend to remove it. See this StackOverflow answer for some tips on how to do that and then continue with the installation instructions below.