Difference between revisions of "Template:Installation/RVM"

From diaspora* project wiki
Jump to: navigation, search
(Set up RVM: Since the version in rubyversion does not match the one rvm wanted on my wheezy system I decided to make a small mention of it.)
(We nowhere mention to run rvm use ruby, nor is Ruby 2.0 required at any stage at the moment. Undo revision 2124 by Nocti (talk))
Line 38: Line 38:
rvm install {{#var:rubyversion}}
rvm install {{#var:rubyversion}}
You might get a message that says something like this if you try to run <tt>rvm use ruby</tt> after sourcing <tt>~/.rvm/scripts/rvm</tt>. In that case you should install the version that is mentioned with <tt>rvm install</tt>.
$ rvm use ruby
ruby-2.0.0-p247 is not installed.
To install do: 'rvm install ruby-2.0.0-p247'

Revision as of 10:26, 20 October 2013


We recommend using Ruby Version Manager it will ensure you're always on the currently recommended Ruby version and cleanly separate your Diaspora installation from all other Ruby applications on your machine. If you opt for not using it ensure your Ruby version is at least 1.9.2-p320, prior versions are incompatible. Be aware that his version is not maintained with security updates from the Ruby core team anymore. We do not support Ruby 2.0 yet. We currently recommend using 1.9.3-p448.

Install RVM

As the user you want to run Diaspora under, that is not as root run:

curl -L dspr.tk/1t | bash

and follow the instructions.

Set up RVM

Ensure the following line is in your ~/.bashrc:

[[ -s "~/.rvm/scripts/rvm" ]] && source "~/.rvm/scripts/rvm"

Now close all open terminals and open a new one!

If you don't have sudo installed or your current user doesn't have the privileges to execute it, run:

rvm autolibs read-only

Then closely watch the output of the next step for something like "Missing required packages:". If it appears, hit Ctrl+C and install all the packages listed there.

Ensure the currently recommend version of Ruby is installed:

rvm install 1.9.3-p448