Difference between revisions of "Template:Installation/RVM"

From diaspora* project wiki
Jump to: navigation, search
(RVM)
Line 3: Line 3:
 
=== RVM ===
 
=== RVM ===
  
We recommend using [http://rvm.io Ruby Version Manager] it will ensure you're always on the currently recommended Ruby version and cleanly separate your Diaspora installation from all other Ruby applications on your machine. If you opt for not using it ensure your Ruby version is at least 1.9.2-p320, prior versions are incompatible. Be aware that this version is not maintained with security updates from the Ruby core team anymore. We currently recommend using the latest release of the {{#var:rubyversion}} series.
+
Мы рекомендуем использовать [http://rvm.io Ruby Version Manager] чтобы вы всегда были обеспечены рекомендуемой(актуальной) версией Ruby и полностью отделить установку вашей Diaspora от всех других приложений Ruby на вашей  машине. Если вы решите не использовать это обеспечение, ваша версия Ruby например 1.9.2-p320 и предыдущие версии могут быть не совместимы ( Знайте, что эта версия больше не поддерживается с обновлениями безопасности от основной команды Ruby). В настоящее время мы рекомендуем использовать последнюю версию {{#var:rubyversion}} серии.
  
==== Install RVM ====
+
==== Установка RVM ====
  
As the user you want to run Diaspora under, that is '''not as root''' run:
+
Вы можете не запускать Diaspora с правами суперпользователя(root) Выполните:
  
 
<syntaxhighlight lang="bash">
 
<syntaxhighlight lang="bash">
Line 13: Line 13:
 
</syntaxhighlight>
 
</syntaxhighlight>
  
and follow the instructions.
+
и следуйте инструкциям.
  
==== Set up RVM ====
+
==== Установка RVM ====
  
Ensure the following line is in your <tt>~/.bashrc</tt>:
+
Убедитесь в наличии следующей строки <tt>~/.bashrc</tt>:
  
 
<syntaxhighlight lang="bash">
 
<syntaxhighlight lang="bash">
Line 24: Line 24:
  
  
'''Now close all open terminals and open a new one!'''
+
'''Теперь закройте все открытые терминалы и открыть новый!'''
  
  
If you '''don't''' have sudo installed or your current user doesn't have the privileges to execute it, run:
+
Если команда sudo не установлена,или ваш текущий пользователь не имеет привилегий для его выполнения, запустите:
 
<syntaxhighlight lang="bash">
 
<syntaxhighlight lang="bash">
 
rvm autolibs read-only
 
rvm autolibs read-only
 
</syntaxhighlight>
 
</syntaxhighlight>
  
'''Closely watch the output of the next step for something''' like "<tt>Missing required packages:</tt>". If it appears, hit <tt>Ctrl+C</tt> and install all the packages listed there. Then rerun that command.
+
'''Внимательно следите за выводом сообщений о следующей стадии''' например "<tt>Missing required packages:(Потеряны необходимые пакеты) </tt>". Если это произошло, нажмите <tt>Ctrl+C</tt> и установите все пакеты перечисленные в нем. Затем выполните эту команду.
  
Ensure the currently recommend version of Ruby is installed:
+
Убедитесь в актуальной версии Ruby :
  
 
{{#tag:syntaxhighlight|
 
{{#tag:syntaxhighlight|
 
rvm install {{#var:rubyversion}}
 
rvm install {{#var:rubyversion}}
 
|lang=bash}}
 
|lang=bash}}

Revision as of 19:56, 23 August 2014


RVM

Мы рекомендуем использовать Ruby Version Manager чтобы вы всегда были обеспечены рекомендуемой(актуальной) версией Ruby и полностью отделить установку вашей Diaspora от всех других приложений Ruby на вашей машине. Если вы решите не использовать это обеспечение, ваша версия Ruby например 1.9.2-p320 и предыдущие версии могут быть не совместимы ( Знайте, что эта версия больше не поддерживается с обновлениями безопасности от основной команды Ruby). В настоящее время мы рекомендуем использовать последнюю версию 2.0 серии.

Установка RVM

Вы можете не запускать Diaspora с правами суперпользователя(root) Выполните:

curl -L dspr.tk/1t | bash

и следуйте инструкциям.

Установка RVM

Убедитесь в наличии следующей строки ~/.bashrc:

[[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm"


Теперь закройте все открытые терминалы и открыть новый!


Если команда sudo не установлена,или ваш текущий пользователь не имеет привилегий для его выполнения, запустите:

rvm autolibs read-only

Внимательно следите за выводом сообщений о следующей стадии например "Missing required packages:(Потеряны необходимые пакеты) ". Если это произошло, нажмите Ctrl+C и установите все пакеты перечисленные в нем. Затем выполните эту команду.

Убедитесь в актуальной версии Ruby :

rvm install 2.0