Template:Installation/RVM

From diaspora* project wiki
< Template:Installation
Revision as of 21:48, 11 January 2017 by Juliangilbey (talk | contribs) (Set up RVM: Comment on stretch/testing differences)
Jump to: navigation, search


RVM

We recommend using Ruby Version Manager it will ensure you're always on the currently recommended Ruby version and cleanly separate your diaspora* installation from all other Ruby applications on your machine. If you opt for not using it ensure your Ruby version is at least 2.1.0, prior versions are incompatible. Be aware that this version is receiving only security updates from the Ruby core team. Note that we don't officially support Ruby 2.2, though we don't expect any issues with it. We currently recommend using the latest release of the 2.3 series.

Install RVM

As the user you want to run diaspora* under, that is not as root, run:

curl -L https://s.diaspora.software/1t | bash

and follow the instructions. If you get GPG signature problems, follow the instructions printed by the command. If those commands give you permission denied errors, change them to 640 for all files and 750 for all folders in the .gnupg folder.

Set up RVM

Ensure the following line is in your ~/.bashrc:

[[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm"

Now close all your terminals and open a new one or run source ~/.bashrc in all of them.

If you don't have sudo installed or your current user doesn't have the privileges to execute it, run:

rvm autolibs read-fail

The next command will check if all dependencies to build Ruby are installed. If these are not met, you will see a list of packages preceded by "Missing required packages:". As root install all the packages listed there for your OS. Then rerun the install command.

Ensure the currently recommend version of Ruby is installed:

rvm install 2.3

Note: If you are installing on testing/stretch, this may give the following error:

Missing required packages: libreadline6-dev libssl-dev

If there are any other packages listed, you will need to install them, but these packages are provided by libreadline-dev and libssl1.0-dev respectively. Otherwise, run the command

rvm autolibs read-only

before rerunning

rvm install 2.3