Difference between revisions of "Updating"

From diaspora* project wiki
Jump to: navigation, search
Line 39: Line 39:
 
bundle # Or DB=postgres bundle for PostgreSQL users
 
bundle # Or DB=postgres bundle for PostgreSQL users
 
</syntaxhighlight>
 
</syntaxhighlight>
 +
 +
Ignore any migration notes this command gives you, they're already done for you or explicitly advised in our changelog!
  
 
Then lets apply updates to the database schema, attention this might take a bit if you got a big database already.
 
Then lets apply updates to the database schema, attention this might take a bit if you got a big database already.

Revision as of 11:56, 24 August 2014

Updating Diaspora is fairly straight forward. But sometimes there are special procedures or updates, so always read the changelog first.

RVM

In case you followed the recommended setup and are on RVM, update RVM first:

rvm get stable

If you are upgrading to diaspora version 0.3 or later, you should install ruby 2.0.0:

rvm install ruby 2.0.0 
rvm use 2.0.0

Updating a production install

We need to update the code first:

git checkout Gemfile.lock db/schema.rb # Discard uninteresting local changes, if any
git pull

Read the output! If you made local modifications to files tracked in git, it might refuse the update or place conflict markers into the files which need to be resolved. If you run on PostgreSQL and get a message about Gemfile.lock try git checkout Gemfile.lock first. If you get one about db/schema.rb try git checkout db/schema.rb.

In case the recommended Ruby version changed you need to install it. Check with

cd .. && cd -

If that outputs a red warning run the command it gives you and do cd .. && cd - again.

Now we need to update the Ruby libraries:

bundle # Or DB=postgres bundle for PostgreSQL users

Ignore any migration notes this command gives you, they're already done for you or explicitly advised in our changelog!

Then lets apply updates to the database schema, attention this might take a bit if you got a big database already.

RAILS_ENV=production bundle exec rake db:migrate # As always add DB=postgres to the command if you're a PostgreSQL user

Update the static content:

bundle exec rake assets:precompile

Now you need to restart Diaspora. To do this with the standard startup method you need to get to the place where you run ./script/server, hit Ctrl+C, open a new shell, and run it again.

Updating a development install

Just checkout the develop branch, pull (from upstream), rebundle and migrate the database:

cd diaspora
git checkout develop
git pull # Or git pull upstream develop if you cloned from your fork
cd .. && cd -
bundle # Or DB=postgres bundle if you use PostgreSQL
rake db:migrate