Installation/Ubuntu/Jammy

From diaspora* project wiki
Jump to: navigation, search
»» Important
diaspora* does not support Ubuntu 22.04 LTS at the moment.


Ubuntu 22.04 ships with OpenSSL version 3, with no option of using OpenSSL 1 instead. The currently available diaspora* releases depend on Ruby 2.7, and are not yet compatible with Ruby 3. Unfortunately, Ruby 2.7 has no official support for OpenSSL 3, so setting up diaspora* on Ubuntu Jammy requires a lot of extra workarounds that the project team currently cannot offer help or support for.

We expect the next major release to support Ruby 3, and thus by extension Ubuntu Jammy. For now, please set up your pod on Ubuntu 20.04, and upgrade the distribution when diaspora* is ready.