Talk:Integrating other social networks

From diaspora* project wiki
Jump to: navigation, search

Valid for Facebook May 2018

I am not particularly skilled and managed to go through the FB setup with zero issues. Might consider updating the "out of date" message. Morriscloud (talk) 00:49, 4 May 2018 (UTC)

New Facebook API

So DenSchub, you're saying the new Facebook API does not need the changes indicated by RDash? --Jaywink (talk) 20:46, 3 October 2014 (UTC)

Changes in Facebook affecting diaspora integration

Today I've been trying to set up the Facebook integration (for app owner only at this stage) for my pod and have found the following:

In diaspora/services when I click "connect" (to Facebook) it leads to Facebook with a message stating:

"Invalid Scopes: publish_actions. This message is only shown to developers. Users of your app will ignore these permissions if present. Please read the documentation for valid permissions at: https://developers.facebook.com/docs/facebook-login/permissions"

Clicking on the link leads to a permissions page but that page no longer lists 'publish_actions'. Doing some web searching I found an item in stackoverflow where a comment states that

"On August 1st, 2018, the Live API publish_actions permission, which allows an app to publish on behalf of its Users, will be reserved for approved partners."

It seems that the possiblity to request 'publish_actions' has been removed already from normal users and the article should be changed to reflect these changes. Cheers. Juboxi (talk) 14:46, 25 July 2018 (UTC)